IFC2X3_ParametricObject_RectangleHollowProfile Class

The IFC2X3_ParametricObject_RectangleHollowProfile class contains the rectangular and hollow profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleHollowProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_RectangleHollowProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_RectangleHollowProfile type exposes the following members.

Properties
  NameDescription
Public propertyDescription
The description of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyExtrusion
The extrusion vector.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyInnerFilletRadius
The inner fillet radius.
Public propertyName
The name of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyObjectType
The object type of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyOrigin
The origin of the extrusion.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyOuterFilletRadius
The outer fillet radius.
Public propertyProfileName
The name of the profile (often empty).
(Inherited from ReferenceModelObjectAttribute.)
Public propertyWallThickness
The wall thickness.
Public propertyXDim
The X dimension.
Public propertyxDir
The X-axis direction.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyYDim
The Y dimension.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next