IFC2X3_ParametricObject_RectangleHollowProfile Class

The IFC2X3_ParametricObject_RectangleHollowProfile class contains the rectangular and hollow profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleHollowProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_RectangleHollowProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_RectangleHollowProfile type exposes the following members.

Properties
  NameDescription
Public propertyInnerFilletRadius
The inner fillet radius.
Public propertyOuterFilletRadius
The outer fillet radius.
Public propertyWallThickness
The wall thickness.
Public propertyXDim
The X dimension.
Public propertyYDim
The Y dimension.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next