Identifier Class |
The Identifier class represents an identifier that holds information
about the identifier number of an object.
Inheritance Hierarchy
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Identifier type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Identifier |
Constructs an empty identifier.
| |
Identifier(Guid) |
Constructs an identifier with the given GUID.
| |
Identifier(Int32) |
Constructs an identifier with the given ID.
| |
Identifier(String) |
Constructs an identifier with the given GUID string.
|
Properties
Name | Description | |
---|---|---|
GUID |
The object's globally unique identifier.
If the GUID value is set manually, the ID is initialized to 0 and the identification is done based on the GUID.
| |
ID |
The identifier number.
If the ID value is set manually, the GUID is initialized to Guid.Empty and the identification is done based on the ID.
| |
ID2 |
The sub identifier number.
If the subID value is set manually, the GUID is initialized to Guid.Empty and the identification is done based on the ID.
|
Methods
Name | Description | |
---|---|---|
Equals(Object) |
Compares the identifier with another object instance.
(Overrides ObjectEquals(Object).) | |
Equals(Identifier) |
Compares the identifier with another identifier instance.
| |
GetHashCode |
Gets the hash number of the identifier.
(Overrides ObjectGetHashCode.) | |
IsValid |
Returns true if the identifier seems to be valid.
The validation is done based on the ID or GUID property.
| |
ToString |
Returns the integer ID as a string.
(Overrides ObjectToString.) |
See Also