ISolid Interface |
The ISolid interface represents a physical object in the model or a drawing created by a part instance.
The solid instance can be used to query the actual geometry of the part.
Namespace: Tekla.Structures.Solid
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ISolid type exposes the following members.
Properties
Name | Description | |
---|---|---|
MaximumPoint |
The maximum axis-aligned point of the solid in the current plane.
| |
MinimumPoint |
The minimum axis-aligned point of the solid in the current plane.
|
Methods
Name | Description | |
---|---|---|
GetEdgeEnumerator |
Returns a new edge enumerator in the current plane.
| |
GetFaceEnumerator |
Returns a new face enumerator in the current plane.
|
See Also