IEvents Interface

Interface for the Events class allows the user to register event listeners for Model events. This interface allows the Marshaling of the Events class with Trimble.Remoting

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public interface IEvents

The IEvents type exposes the following members.

Methods
  NameDescription
Public methodOnInterrupted
Called when uesr interrupts.
Public methodOnModelSaveInfo
Called when model is saved.
Public methodOnUndoClicked
Called when user clicks undo.
Public methodRegister
Registers the instance to listen to the specified events. More event delegates should not be added without calling UnRegister first.
Public methodUnRegister
Unregisters the instance from listening to events.
Top
Events
  NameDescription
Public eventClashCheckDone
The ClashCheckDone event is raised just after clash check is completed.
Public eventClashDetected
The ClashDetected event is raised just after the detection of each clash. The clash information is saved before the event is triggered.
Public eventCommandStatusChange
The CommandStatusChange event is raised when a command is started/ended.
Public eventInterrupted
Occurs when user interrupts.
Public eventModelChanged
The ModelChanged event is raised just after some changes have been made to the model.

Note, this event is however not triggered when UNDO or REDO are performed.

Public eventModelLoad
The ModelLoad event is raised just after a model has been loaded.
Public eventModelLoadInfo
The ModelLoadInfo event is raised just after a model has been loaded with the model load information as a string parameter.
Public eventModelObjectChanged
The ModelObjectChanged event is raised just after some changes have been made to the model objects.

Note, this event is triggered when UNDO or REDO are performed!!

Public eventModelObjectNumbered
The ModelObjectNumbered event is raised when model object is numbered.
Public eventModelSave
The ModelSave event is raised just after a model has been saved.
Public eventModelSaveAs
The ModelSaveAs event is raised just after a model has been saved using save as.
Public eventModelSaveInfo
The ModelSave event is raised just after a model has been saved with the model save information as a string parameter.
Public eventModelUnloading
The ModelUnloading event is raised just before the model is unloaded.
Public eventNumbering
The Numbering event is raised just after a model has been numbered.
Public eventProjectInfoChanged
The ProjectInfoChanged event is raised just after some changes have been made to the project info.

Note, this event is however not triggered when UNDO or REDO are performed.

Public eventSelectionChange
The SelectionChange event is raised when the user changes the current selection inside Tekla Structures.
Public eventTeklaStructuresExit
The TeklaStructuresExit event is raised just before Tekla Structures exits. After this event has been called the user will no longer be able to perform any calls to Tekla Structures.
Public eventViewCameraChanged
Occurs when view camera is changed.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next