IEvents Interface

Interface for the Events class allows the user to register event listeners for Drawings events. This interface allows the Marshaling of the Events class with Trimble.Remoting

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public interface IEvents

The IEvents type exposes the following members.

Methods
  NameDescription
Public methodRegister
Registers the instance to listen to the specified events.
Public methodUnRegister
Unregisters the instance from listening to events.
Top
Events
  NameDescription
Public eventDrawingChanged
The DrawingChanged event is raised when the drawing has been changed and the database is committed.
Public eventDrawingDeleted
The DrawingDeleted event is raised when a drawing has been deleted.
Public eventDrawingInserted
The DrawingInserted event is raised when a drawing has been inserted.
Public eventDrawingReadyForIssuingChange
The DrawingReadyForIssuingChange event is raised just after a drawing is marked or unmarked ready for issuing.
Public eventDrawingStatusChanged
The DrawingStatusChanged event is raised when the drawing status has changed.
Public eventDrawingUpdated
The DrawingUpdated event is raised when the drawing has been inserted, deleted or modified, and the database is committed.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next