HierarchicObject Class

The HierarchicObject class defines an object in a tree-structured hierarchy. The hierarchy structure is defined by hierarchical definitions which the hierarchical objects instantiate. Hierarchical objects may contain other hierarchical objects, thus forming a sub-hierarchy, or model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class HierarchicObject : ModelObject

The HierarchicObject type exposes the following members.

Constructors
  NameDescription
Public methodHierarchicObject
Creates a new hierarchical object instance.
Public methodCode exampleHierarchicObject(Identifier)
Instantiates a hierarchical object with a known identifier. The instantiation has to be done before the hierarchical definition instance can be selected.
Top
Properties
  NameDescription
Public propertyDefinition
The hierarchical definition which the hierarchical object is associated with.
Public propertyFather
The father of the hierarchical object.
Public propertyHierarchicChildren
An array list that contains the hierarchical object's hierarchical children (of the type hierarchical object).
Public propertyName
The name of the hierarchical object.
Top
Methods
  NameDescription
Public methodAddObjects
Associates model objects with the hierarchical object. Fails if the hierarchical definition doesn't exist in the model.
Public methodDelete
Deletes the hierarchical object instance from the model. The ID must be set.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the hierarchical object instance in the model.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the hierarchical object instance in the model. The ID must be set.
(Overrides ModelObjectModify.)
Public methodRemoveObjects
Removes associations to the given list of model objects. Fails if the hierarchical definition doesn't exist in the model.
Public methodSelect
Selects the hierarchical object instance from the model. The ID must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           HierarchicDefinition scenarioDefinition = new HierarchicDefinition();
           scenarioDefinition.Name = "Scenario type";
           scenarioDefinition.HierarchyType = HierarchicDefinitionTypeEnum.DOT_HIERARCHIC_TASK_SCENARIO;
           scenarioDefinition.Insert();

           HierarchicObject scenario = new HierarchicObject();
           scenario.Name = "First scenario";
           scenario.Definition = scenarioDefinition;
           scenario.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next