HatchAttributes Class

The HatchAttributes base class, inherited by ModelObjectHatchAttributes and GraphicObjectHatchAttributes, contains hatch attributes.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public abstract class HatchAttributes : GenericAttributesBase

The HatchAttributes type exposes the following members.

Properties
  NameDescription
Public propertyAngle
The angle in which to draw the hatch.
Public propertyBackgroundColor
The background color of the hatch.
Public propertyColor
The color of the hatch.
Public propertyDrawBackgroundColor
Sets whether the background color will be enabled or disabled for the hatch. See also: BackgroundColor.
Public propertyFactorType
The type of the hatch factor.
Public propertyName
The name of the hatch. If an empty string is given as hatch name it will become "None".
Public propertyScaleX
The scale value of the hatch in the X-direction.
Public propertyScaleY
The scale value of the hatch in the Y-direction.
Public propertyTrueBackgroundColor
The true color (rgb enabled) of the hatch background.
Public propertyTrueColor
The true color (RGB enabled) of the hatch.
Top
Methods
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next