GridLineGridLineAttributes Class |
The GridLineAttributes class is the attributes class for the grid line.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGridLineGridLineAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGridLineGridLineAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The GridLineGridLineAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
GridLineGridLineAttributes |
Creates a new default grid line attributes instance that loads standard attributes.
| |
GridLineGridLineAttributes(String) |
Creates a new grid line attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
CustomPresentation |
Custom presentation GUID to be applied to the object type
| |
DrawOnlyTextLabelsNotGridLines |
Set as true if you don't want to draw the grid lines, only show the grid lines' text labels.
| |
DrawTextAtEndOfGridLine |
Set as true if you want to show the grid line's text label at the end of the line.
| |
DrawTextAtStartOfGridLine |
Set as true if you want to show the grid line's text label at the start of the line.
| |
Font |
The grid line's font attributes.
| |
Frame |
The frame attributes of the grid line's label.
| |
Line |
The grid line's line attributes.
| |
OffsetAtEndOfLine |
The offset for the end of the grid line.
| |
OffsetAtStartOfLine |
The offset for the beginning of the grid line.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also