GridCylindricalSurface Class |
The GridCylindricalSurface class defines a user defined (possibly magnetic) cylindrical surface helping in
modeling work. A grid cylindrical surface must always belong to a parent grid instance.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelGridSurface
Tekla.Structures.ModelGridCylindricalSurface
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelGridSurface
Tekla.Structures.ModelGridCylindricalSurface
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The GridCylindricalSurface type exposes the following members.
Constructors
Name | Description | |
---|---|---|
GridCylindricalSurface |
Creates a new grid plane instance.
The default values are as follows:
| |
GridCylindricalSurface(Arc, Double, String) |
Creates a new grid plane instance taking the plane and label as input.
|
Properties
Name | Description | |
---|---|---|
CylinderBase |
The arc that represents the base of the cylindrical surface. The cylinder is then extruded along the normal
direction of the arc, with the height given by CylinderHeight"
| |
CylinderHeight |
Height of the cylinder along the normal direction of the CylinderBase arc.
| |
DrawingVisibility |
The visibility of the grid surface in drawings.
(Inherited from GridSurface.) | |
ExtensionAbove |
The line extension above.
(Inherited from GridSurface.) | |
ExtensionBelow |
The line extension below.
(Inherited from GridSurface.) | |
ExtensionLeft |
The line extension on the left.
(Inherited from GridSurface.) | |
ExtensionRight |
The line extension on the right.
(Inherited from GridSurface.) | |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsMagnetic |
Whether the grid surface is magnetic or not.
(Inherited from GridSurface.) | |
IsManual |
Gets or sets if the line was manually created.
(Inherited from GridSurface.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
Label |
The label for the grid surface.
(Inherited from GridSurface.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Parent |
The parent grid of the grid surface.
(Inherited from GridSurface.) |
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the grid surface with the given ID.
(Inherited from GridSurface.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the grid surface into the model.
(Inherited from GridSurface.) | |
Modify |
Modifies the grid plane with the given ID.
(Overrides GridSurfaceModify.) | |
Select |
Selects the grid surface with the given ID.
(Inherited from GridSurface.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using System; using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public bool Example1() { var cylindricalSurface = new GridCylindricalSurface(); Arc cylinderBase = new Arc(new Point(0,0,0), new Point(6000,0,0), new Vector(0,0,1), Math.PI); double cylinderHeight = 6000.0; cylindricalSurface.CylinderBase = cylinderBase; cylindricalSurface.CylinderHeight = cylinderHeight; return cylindricalSurface.Insert(); } }
See Also