GridBase Constructor

Creates a new grid instance.

The default values are as follows:

  • Name = "Grid";
  • CoordinateX = "0.00 4*3000.00";
  • CoordinateY = "0.00 5*6000.00";
  • CoordinateZ = "0.00 6000.00 8000.00 9000.00";
  • LabelX = "A B C D E";
  • LabelY = "1 2 3 4 5 6";
  • LabelZ = "+0 +6000 +8000 +9000";
  • ExtensionLeftX = 2000.0;
  • ExtensionLeftY = 2000.0;
  • ExtensionLeftZ = 2000.0;
  • ExtensionRightX = 2000.0;
  • ExtensionRightY = 2000.0;
  • ExtensionRightZ = 2000.0;
  • IsMagnetic = false;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public GridBase()
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next