GraphicObjectGraphicObjectAttributes Class |
The GraphicObjectAttributes class is the attributes class of the graphic object.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The GraphicObjectGraphicObjectAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
GraphicObjectGraphicObjectAttributes |
Creates a new graphic object attributes instance.
| |
GraphicObjectGraphicObjectAttributes(String) |
Creates a new graphic object attributes instance using the given attribute file's filename.
|
Properties
Name | Description | |
---|---|---|
Line |
The line attributes of the graphic object. A graphic object always consists of lines.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) | |
LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |
See Also