SymbolLibraryGetSymbolLibraries Method (Boolean)

Gets the names of the available symbol files in the current Tekla Structures environment, in the "symbols" directory, without the suffix.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static StringList GetSymbolLibraries(
	bool forceRefresh
)

Parameters

forceRefresh
Type: SystemBoolean
If set to true, always lists the files again (slower).

Return Value

Type: StringList
A list of symbol file names or null if failed.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next