AnalysisResultGetResults Method |
Get analysis results.
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static List<AnalysisResult> GetResults( AnalysisResultObjectTypeEnum? objectType, int? objectId, AnalysisResultResultPositionEnum? position, Point point, AnalysisResultValueTypeEnum? valueType, bool sort )
Parameters
- objectType
- Type: SystemNullableAnalysisResultObjectTypeEnum
The object type. - objectId
- Type: SystemNullableInt32
The object id or number (also object type must be given). - position
- Type: SystemNullableAnalysisResultResultPositionEnum
The position. - point
- Type: Tekla.Structures.Geometry3dPoint
The position point (when position is POSITION_BY_COORDINATES). - valueType
- Type: SystemNullableAnalysisResultValueTypeEnum
The value type. - sort
- Type: SystemBoolean
True if values to be sorted.
Return Value
Type: ListAnalysisResultThe results.
See Also