ReinforcementGetRebarGeometriesWithoutClashes Method |
Retrieves a list of physical reinforcing bars (of type RebarGeometry).
These objects contain physical points in the 3D space of each reinforcing bar as shown in model view.
In case rebar polygon clashes with itself, physical points are moved to avoid clashing.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- withHooks
- Type: SystemBoolean
A parameter to determine whether the hook points should be included in the rebar geometry or not.
Return Value
Type: ArrayListAn array list that contains the RebarGeometry objects.
See Also