ReinforcementGetRebarComplexGeometries Method (Boolean, Boolean, Boolean, ReinforcementRebarGeometrySimplificationTypeEnum)

Retrieves a list of physical reinforcing bars (of type RebarComplexGeometry). These objects contain physical curves in the 3D space of each reinforcing bar as shown in model view. RebarComplexGeometry only differs from RebarGeometry by containing a polycurve (of Arc and LineSegment objects) rather than a polyline. The polycurve only contains arcs if the "simplified" parameter is RATIONALIZED or FABRICATION. If "simplified" is NONE, any arcs will be returned as a series of line segments.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public List<RebarComplexGeometry> GetRebarComplexGeometries(
	bool withHooks,
	bool withoutClashes,
	bool lengthAdjustments,
	ReinforcementRebarGeometrySimplificationTypeEnum simplified
)

Parameters

withHooks
Type: SystemBoolean
A parameter to determine whether the hook points should be included in the rebar geometry or not.
withoutClashes
Type: SystemBoolean
A parameter to determine whether self-clash avoidance should be included in the rebar geometry or not.
lengthAdjustments
Type: SystemBoolean
A parameter to determine whether rounding and step tapering should be included in the rebar geometry or not.
simplified
Type: Tekla.Structures.ModelReinforcementRebarGeometrySimplificationTypeEnum
A parameter to determine whether the "simplified" rebar shape recognition geometry should be returned.

Return Value

Type: ListRebarComplexGeometry
A list of RebarComplexGeometrys.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next