ModelObjectSelectorGetObjectsByBoundingBox Method

Returns an enumerator of the model objects in the current model colliding with the given geometrical bounding box. Note that this method uses approximate bounding boxes and thus is NOT EXACT, and may return objects not necessarily colliding with the given box but only being somewhere near to it.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public ModelObjectEnumerator GetObjectsByBoundingBox(
	Point MinPoint,
	Point MaxPoint
)

Parameters

MinPoint
Type: Tekla.Structures.Geometry3dPoint
The minimum point of the bounding box.
MaxPoint
Type: Tekla.Structures.Geometry3dPoint
The maximum point of the bounding box.

Return Value

Type: ModelObjectEnumerator
A model object enumerator of the model objects colliding with the given bounding box.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next