EnvironmentFilesGetMultiDirectoryFileList Method (ListString, String)

Gets a list of files with the given extension from the given search directories and from XS_FIRM, XS_PROJECT subdirectories.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static List<string> GetMultiDirectoryFileList(
	List<string> searchDirectories,
	string fileExtension
)

Parameters

searchDirectories
Type: System.Collections.GenericListString
The search directories to be used.
fileExtension
Type: SystemString
The file extension to be used.

Return Value

Type: ListString
A list of found file names without the file extension.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next