ModelHistoryGetModifications Method (String, IEnumerableModelObjectModelObjectEnum, ModificationStamp)

Lookup modifications since previous call of TakeModifications() without resetting the modstamp, with object type filtering

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static ModificationInfo GetModifications(
	string Name,
	IEnumerable<ModelObjectModelObjectEnum> ObjectTypes,
	ModificationStamp PrevStamp = null
)

Parameters

Name
Type: SystemString
Name of reference which is used for collecting modifications and which is updated. Intended use is to assign an unique name for each client application which needs to be informed of the model updates. Maximum length is 79 characters.
ObjectTypes
Type: System.Collections.GenericIEnumerableModelObjectModelObjectEnum
Types of object to select. Empty or null selects all types.
PrevStamp (Optional)
Type: Tekla.Structures.Model.HistoryModificationStamp
When specified, default value of reference if is it not found

Return Value

Type: ModificationInfo
All modifications which happened since the last call
Remarks
Same as GetModifications(String, ModificationStamp), but returns only the types listed in ObjectTypes.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next