ModelObjectGetIntegerReportProperties Method

Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool GetIntegerReportProperties(
	ArrayList names,
	ref Hashtable values
)

Parameters

names
Type: System.CollectionsArrayList
An array list containing the names of the properties.
values
Type: System.CollectionsHashtable
The return value, a hash table that contains all the values that were retrieved successfully.

Return Value

Type: Boolean
True if at least one single property was retrieved successfully.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next