TeklaStructuresFilesGetFileDictionaryByExtension Method

Retrieves a dictionary of file names and their corresponding paths from multiple directories.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static Dictionary<string, string> GetFileDictionaryByExtension(
	string fileExtension,
	string modelPath
)

Parameters

fileExtension
Type: SystemString
The file extension to filter the files by.
modelPath
Type: SystemString
The model path.

Return Value

Type: DictionaryString, String
A dictionary containing file names without the extension and their paths.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next