ModelObjectSelectorGetAllObjectsWithType Method (ModelObjectModelObjectEnum)

Returns an enumerator of all the model objects in the current model with the given type.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public ModelObjectEnumerator GetAllObjectsWithType(
	ModelObjectModelObjectEnum Enum
)

Parameters

Enum
Type: Tekla.Structures.ModelModelObjectModelObjectEnum
The type of the objects to return.

Return Value

Type: ModelObjectEnumerator
A model object enumerator of all the model objects with the given type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next