AnalysisObjectSelectorGetAllObjectsWithType Method |
Returns an enumerator of all the model objects in the current model with the given type.
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public AnalysisObjectEnumerator GetAllObjectsWithType( AnalysisObjectAnalysisObjectEnum ObjectToSelectType, string AnalysisModelName )
Parameters
- ObjectToSelectType
- Type: Tekla.Structures.AnalysisAnalysisObjectAnalysisObjectEnum
The type of the objects to return. - AnalysisModelName
- Type: SystemString
The name of the analysis model.
Return Value
Type: AnalysisObjectEnumeratorA model object enumerator of all the model objects with the given type.
See Also