ShapeItemGetAllMetadataKeys Method

Get the Shape item's metadata keys.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public List<string> GetAllMetadataKeys()

Return Value

Type: ListString
A list of strings containing the keys.
Examples
public void SetMetadataTest()
{
    var polymesh = CreateSomeValidBrep();
    var shapeItem = new ShapeItem
    {
        Name = "TestFileName",
        ShapeFacetedBrep = polymesh,
        UpAxis = ShapeUpAxis.Z_Axis
    };

    shapeItem.Insert();

    var keys = shapeItem.GetAllMetadataKeys();
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next