Frame Class |
The Frame class defines a frame that can be given to objects, including texts.
A frame is a box around the object. You can specify the color and shape of the box.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Frame type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Frame(FrameTypes, DrawingColors) |
Creates a new frame instance with the specified frame type and color.
| |
Frame(FrameTypes, TeklaDrawingColor) |
Creates a new frame instance with the specified frame type and RGB color.
|
Properties
Name | Description | |
---|---|---|
Color |
The frame's color.
| |
TrueColor |
The true color (RGB enabled) of the frame.
| |
Type |
The frame's type (square, round, dashed...).
|
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
| |
GetAxisAlignedBoundingBox |
Returns the bounding box of the frame in the global axis coordinate system.
| |
GetObjectAlignedBoundingBox |
Returns the bounding box of the frame in the local coordinate system.
| |
IsEqual |
Compares the current object with an object of the same type.
|
See Also