DistanceFromFractionalFeetAndInchesString Method (String) |
Creates a distance from a string representation of fractional feet and inches.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- text
- Type: SystemString
The distance string.
Return Value
Type: DistanceThe representation of the specified distance.
Exceptions
Exception | Condition |
---|---|
FormatException | Thrown if the text does not represent a distance. |
Examples
This example shows how to parse a Distance instance from a fractional
string representation of feet and inches.
using Tekla.Structures.Datatype; public class Example { public void Example1() { Distance distance = Distance.FromFractionalFeetAndInchesString("3' 3/4"); } }
See Also