FacetedBrepWithNormals Constructor

Initializes a new instance of the FacetedBrepWithNormals class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public FacetedBrepWithNormals(
	Vector[] vertices,
	int[][] outerWires,
	IDictionary<int, int[][]> innerWires,
	Vector[] normals
)

Parameters

vertices
Type: Tekla.Structures.Geometry3dVector
The vertex geometries.
outerWires
Type: SystemInt32
The outer wires as a two dimensional array. Integer indexes are used for identifying the corresponding vertex for the node in the wire from the array provided by parameter vertices.
innerWires
Type: System.Collections.GenericIDictionaryInt32, Int32
The inner wires also known as inner loops or holes.
normals
Type: Tekla.Structures.Geometry3dVector
Normal unit vectors for each vertex in vertices.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next