DrawingItemExport Method |
Exports the drawing item in the catalog to given file name.
If path is not given drawing is exported to model folder.
If filename is empty drawing name is used as filename.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- filename
- Type: SystemString
The export file name of the drawing item.
Return Value
Type: BooleanTrue on success.
Examples
using System; using Tekla.Structures.Catalogs; public class Example { public void Example1() { DrawingItem item = new DrawingItem(); if (item.Select()) { string filename = System.IO.Path.GetTempPath() + item.Name; if (item.Export(ref filename)) { Console.WriteLine(item.Name + " exported successfully"); } } } }
See Also