BoltItemExportBoltStandard Method

Exports the bolt item standard + needed bolt catalog items in *.bass-format to the to given file name. If path is not given bolt standard + items are exported to model folder. If filename is empty bolt standard name is used as filename.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool ExportBoltStandard(
	ref string filename
)

Parameters

filename
Type: SystemString
The export file name of the bolt assembly.

Return Value

Type: Boolean
True on success.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           CatalogHandler catalogHandler = new CatalogHandler();

           if (catalogHandler.GetConnectionStatus())
           {
               BoltItemEnumerator boltItemEnumerator = CatalogHandler.GetBoltItems();

               while (boltItemEnumerator.MoveNext())
               {
                   BoltItem boltItem = boltItemEnumerator.Current as BoltItem;

                   if (boltItem.Standard == "A325N")
                   {
                       boltItem.ExportBoltStandard(System.IO.Path.GetTempPath() + "\\" + boltItem.Standard);
                       Result = true;
                       break;
                   }
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next