ErrorDialog Class |
The ErrorDialog class represents the common error dialog for the Open API.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogErrorDialog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.DialogErrorDialog
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Methods
Name | Description | |
---|---|---|
Show(Exception, ErrorDialogSeverity) |
Shows a new error dialog.
| |
Show(String, ListString, ErrorDialogSeverity) |
Shows a new error dialog.
| |
Show(String, String, ErrorDialogSeverity) |
Shows a new error dialog.
|
See Also