EnvironmentVariables Class

The EnvironmentVariables class contains a sorted list specializing in getting active environment variables and advanced option settings. It also checks options.ini files in the active model folder as well as options_user.ini files.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Dialog.UIControlsEnvironmentVariables

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static class EnvironmentVariables

The EnvironmentVariables type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd
Adds a variable to the list.
Public methodStatic memberGet
Gets a key.
Public methodStatic memberGetEnvironmentVariable
Gets an environment variable.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next