EnvironmentFiles Class |
The EnvironmentFiles class is for the paths where the attributes file will be searched for.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The EnvironmentFiles type exposes the following members.
Constructors
Name | Description | |
---|---|---|
EnvironmentFiles | Initializes a new instance of the EnvironmentFiles class |
Properties
Name | Description | |
---|---|---|
PropertyFileDirectories |
The directories where to look for property files.
|
Methods
Name | Description | |
---|---|---|
GetAttributeFile(String) |
Gets a file info representing the first match in the standard property file directories.
| |
GetAttributeFile(ListString, String) | Obsolete.
Gets a file info representing the first match in the search directories.
| |
GetAttributeFiles |
Gets attribute files with specified suffix from model, XS_FIRM and XS_PROJECT directories and subdirectories.
| |
GetMultiDirectoryFileList(String) |
Gets a list of files with the given extension from the default search directories.
| |
GetMultiDirectoryFileList(ListString, String) |
Gets a list of files with the given extension from the given search directories and from XS_FIRM, XS_PROJECT subdirectories.
| |
GetStandardPropertyFileDirectories |
Gets the paths where to look for the property files.
| |
IsValidDirectory |
Checks if a directory is valid.
|
See Also