EmbeddedObjectAttributes Class |
The EmbeddedObjectAttributes class contains attributes for embedded objects.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingEmbeddedObjectAttributes
Tekla.Structures.DrawingTextFileTextFileAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingEmbeddedObjectAttributes
Tekla.Structures.DrawingTextFileTextFileAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The EmbeddedObjectAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
EmbeddedObjectAttributes |
Initializes a new instance of the EmbeddedObjectAttributes class that loads standard attributes.
| |
EmbeddedObjectAttributes(String) |
Initializes a new instance of the EmbeddedObjectAttributes class that loads given attributes.
|
Properties
Name | Description | |
---|---|---|
Frame |
Gets or sets the frame.
| |
Scaling |
Gets or sets the scaling type.
| |
XScale |
Gets or sets the X scaling value. Changing this property
will set the scaling type to ScaleXY.
| |
YScale |
Gets or sets the Y scaling value. Changing this property
will set the scaling type to ScaleXY.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the specified attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also