DwgObject Class |
The DwgObject class defines a DWG or DXF object that can be inserted into a drawing.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingEmbeddedObjectBase
Tekla.Structures.DrawingDwgObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingEmbeddedObjectBase
Tekla.Structures.DrawingDwgObject
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DwgObject type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DwgObject(ViewBase, Point, String) |
Creates a new DwgObject instance with the given parameters.
| |
DwgObject(ViewBase, Point, String, EmbeddedObjectAttributes) |
Creates a new DwgObject instance using the specified attributes.
| |
DwgObject(ViewBase, Point, Size, String) |
Creates a new DwgObject instance with the given parameters.
| |
DwgObject(ViewBase, Point, Size, String, EmbeddedObjectAttributes) |
Creates a new DwgObject instance using the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Angle |
Gets or sets the angle (in degrees).
(Inherited from EmbeddedObjectBase.) | |
Attributes |
Gets or sets the attributes.
(Inherited from EmbeddedObjectBase.) | |
FileName |
Gets or sets the file name defining the embedded object.
(Inherited from EmbeddedObjectBase.) | |
InsertionPoint |
Gets or sets the insertion point.
(Inherited from EmbeddedObjectBase.) | |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
Size |
Gets or sets the size of the frame of the embedded object.
(Inherited from EmbeddedObjectBase.) |
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the embedded object.
(Inherited from EmbeddedObjectBase.) | |
GetAxisAlignedBoundingBox |
Gets the bounding box for the current object in the global axis coordinate system.
(Inherited from EmbeddedObjectBase.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetObjectAlignedBoundingBox |
Gets the bounding box for the current object in its local coordinate system.
(Inherited from EmbeddedObjectBase.) | |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Inserts the embedded object.
(Inherited from EmbeddedObjectBase.) | |
IsEqual |
Compares the current object with an object of the same type.
(Inherited from EmbeddedObjectBase.) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the embedded object.
(Inherited from EmbeddedObjectBase.) | |
MoveObjectRelative |
Moves the object according to the given move vector.
(Inherited from EmbeddedObjectBase.) | |
Resize |
Resizes the object. The scaling type is changed to ScaleToFit.
(Inherited from EmbeddedObjectBase.) | |
Select |
Selects the embedded object.
(Inherited from EmbeddedObjectBase.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
Examples
The following example shows how to embed a DXF file to a drawing with
the scale 0.5:
using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; using System.IO; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); ViewBase _view = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews().Current as ViewBase; EmbeddedObjectAttributes attributes = new EmbeddedObjectAttributes(); attributes.XScale = 0.5; attributes.YScale = 0.5; DwgObject dxf = new DwgObject(_view, new Point(100, 100), Path.GetFullPath("my_dxf.dxf"), attributes); dxf.Insert(); } }
See Also