DrawingObject Class |
The DrawingObject class is an abstract base class for all the objects in the drawing.
All drawing objects have a database identifier and belong to some view.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DrawingObject type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes of the current object.
Only attributes of the same type as the object are allowed.
Methods
Name | Description | |
---|---|---|
GetDrawing |
Gets the drawing where the drawing object is.
GetRelatedObjects |
Gets the related objects of the current object.
| |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
GetView |
Gets the view where the drawing object is.
IsEqual |
Compares the current object with the given object.
Checks every field of both objects for equality.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
ToString |
Changes the string presentation of the drawing object.
(Overrides ObjectToString.) |
See Also
Reference
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDetailMark
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingDimensionLink
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingEmbeddedObjectBase
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingLeaderLine
Tekla.Structures.DrawingLevelMark
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingPlugin
Tekla.Structures.DrawingSectionMarkBase
Tekla.Structures.DrawingSymbol
Tekla.Structures.DrawingText
Tekla.Structures.DrawingViewBase
Tekla.Structures.DrawingWeldMark
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDetailMark
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingDimensionLink
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingEmbeddedObjectBase
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingLeaderLine
Tekla.Structures.DrawingLevelMark
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingPlugin
Tekla.Structures.DrawingSectionMarkBase
Tekla.Structures.DrawingSymbol
Tekla.Structures.DrawingText
Tekla.Structures.DrawingViewBase
Tekla.Structures.DrawingWeldMark