DrawingObject Class |
The DrawingObject class is an abstract base class for all the objects in the drawing.
All drawing objects have a database identifier and belong to some view.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DrawingObject type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes of the current object.
Only attributes of the same type as the object are allowed.
| |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the instance from the database.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
| |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetRelatedObjects |
Gets the related objects of the current object.
| |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
| |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
| |
Insert |
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.) | |
IsEqual |
Compares the current object with the given object.
Checks every field of both objects for equality.
| |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the instance in the database.
(Inherited from DatabaseObject.) | |
Select |
Selects the object instance from the database.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Overrides ObjectToString.) |
See Also
Reference
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDetailMark
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingDimensionLink
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingEmbeddedObjectBase
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingLeaderLine
Tekla.Structures.DrawingLevelMark
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingPlugin
Tekla.Structures.DrawingSectionMarkBase
Tekla.Structures.DrawingSymbol
Tekla.Structures.DrawingText
Tekla.Structures.DrawingViewBase
Tekla.Structures.DrawingWeldMark
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDetailMark
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingDimensionLink
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingEmbeddedObjectBase
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingLeaderLine
Tekla.Structures.DrawingLevelMark
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingPlugin
Tekla.Structures.DrawingSectionMarkBase
Tekla.Structures.DrawingSymbol
Tekla.Structures.DrawingText
Tekla.Structures.DrawingViewBase
Tekla.Structures.DrawingWeldMark