DrawingItem Class

The DrawingItem class contains information from the drawings in the master drawing catalog.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsDrawingItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class DrawingItem

The DrawingItem type exposes the following members.

Constructors
  NameDescription
Public methodDrawingItem
Creates a new drawing item instance.
Top
Properties
  NameDescription
Public propertyFiles
The files belonging to drawing item.
Public propertyName
The drawing item's name.
Public propertyType
The files belonging to drawing item.
Top
Methods
  NameDescription
Public methodCode exampleExport
Exports the drawing item in the catalog to given file name. If path is not given drawing is exported to model folder. If filename is empty drawing name is used as filename.
Public methodSelect
Selects the drawing item in the drawing catalog.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next