DrawingUpToDateStatus Enumeration |
The drawing up to date status.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
DrawingIsUpToDate | 1 | The drawing is up to date. | |
PartsWereModified | 2 | Some parts in the drawing were modified since the last update. | |
DrawingIsUpToDateButMayNeedChecking | 4 | The drawing is up to date but may need checking. | |
IncludedDrawingModified | 5 | The included drawing was modified. | |
OriginalPartDeleted | 6 | The original part from which the drawing was created was deleted since the last update. | |
AllPartsDeleted | 7 | All parts were deleted. | |
NumberOfPartsInNumberingSeriesIncreased | 8 | The number of parts in the numbering series has increased since the last update. | |
NumberOfPartsInNumberingSeriesDecreased | 9 | The number of parts in the numbering series has decreased since the last update. | |
DrawingWasCloned | 10 | The drawing was cloned from another drawing. | |
DrawingWasUpdated | 11 | The drawing was updated. | |
CopiedViewChanged | 12 | The copied view changed. | |
DrawingWasSplitted | 13 | The drawing was splitted (cloned) during numbering. | |
MovedViewDeleted | 14 | The moved view was deleted. | |
MovedViewLabelChanged | 15 | The moved view symbol has changed. |
See Also