GraphicsDrawerDrawTextToView Method

Draws a temporary text to the specified view. You can set the view Identifier.ID = 0 for current active view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public int DrawTextToView(
	Point Location,
	string Text,
	Color Color,
	View View
)

Parameters

Location
Type: Tekla.Structures.Geometry3dPoint
The location of the text's top-left corner.
Text
Type: SystemString
The text to be drawn. The maximum length is 511 characters.
Color
Type: Tekla.Structures.Model.UIColor
The color of the text. The transparency value of the color is ignored.
View
Type: Tekla.Structures.Model.UIView
The model view (ID = 0 for current active view)

Return Value

Type: Int32
The id of the inserted text.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next