DPMPrinterAttributes Class

The DPMPrinterAttributes class contains the attributes for controlling the printing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class DPMPrinterAttributes : GenericAttributesBase

The DPMPrinterAttributes type exposes the following members.

Constructors
  NameDescription
Public methodDPMPrinterAttributes
Creates a new PrintAttributes instance.
Top
Properties
  NameDescription
Public propertyColorMode
Output color mode.
Public propertyNumberOfCopies
The number of copies of each drawing to print. Only applicable for printing to a printer.
Public propertyOpenFileWhenFinished
Whether to open file when finished.
Public propertyOrientation
The print orientation type.
Public propertyOutputFileName
Output file name and path. Applicable in PDF printing.
Public propertyOutputType
The printing output type.
Public propertyPaperSize
The paper size name.
Public propertyPrinterName
The printer name.
Public propertyPrintToMultipleSheet
Whether to print to multiple sheets.
Public propertyScaleFactor
The print scale factor.
Public propertyScalingMethod
The print scaling method.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next