dotdiaUnitTypes_e Enumeration |
Specifies the Tekla Structures unit types.
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
INPUT_BOOLEAN | -3 | The input boolean. | |
INPUT_INTEGER | -2 | The input integer. | |
INPUT_STRING | -1 | The input string. | |
INPUT_NONE | 0 | The input none. | |
INPUT_RATIO_UNIT | 1 | The input ratio unit. | |
INPUT_STRAIN_UNIT | 2 | The input strain unit. | |
INPUT_ANGLE_UNIT | 5 | The input angle unit. | |
OUTPUT_ANGLE_UNIT | 6 | The output angle unit. | |
INPUT_SECTION_ANGLE_UNIT | 7 | The input section angle unit. | |
INPUT_LENGTH_UNIT | 10 | The input length unit. | |
OUTPUT_LENGTH_UNIT | 11 | The output length unit. | |
INPUT_DEFORMATION_UNIT | 12 | The input deformation unit. | |
OUTPUT_DEFORMATION_UNIT | 13 | The output deformation unit. | |
INPUT_DIMENSION_UNIT | 14 | The input dimension unit. | |
INPUT_RADIUSOFINERTIA_UNIT | 16 | The input radius of inertia unit. | |
INPUT_AREA_UNIT | 20 | The input area unit. | |
OUTPUT_REINFAREA_UNIT | 21 | The output reinforced area unit. | |
OUTPUT_TRANSVREINF_UNIT | 22 | The output transverse reinforcement unit. | |
INPUT_AREAPERLENGTH_UNIT | 23 | The input area per length unit. | |
OUTPUT_VOLUME_UNIT | 30 | The output volume unit. | |
INPUT_SECTIONMODULUS_UNIT | 31 | The input section modulus unit. | |
INPUT_VOLUME_UNIT | 32 | The input volume unit. | |
INPUT_MOMENTOFINERTIA_UNIT | 40 | The input moment of inertia unit. | |
INPUT_TORSIONCONSTANT_UNIT | 41 | The input torsion constant unit. | |
INPUT_WARPINGCONSTANT_UNIT | 60 | The input warping constant unit. | |
INPUT_FORCE_UNIT | 100 | The input force unit. | |
OUTPUT_FORCE_UNIT | 101 | The output force unit. | |
INPUT_WEIGHT_UNIT | 102 | The input weight unit. | |
OUTPUT_WEIGHT_UNIT | 103 | The output weight unit. | |
INPUT_DISTRIBLOAD_UNIT | 110 | The input distributed load unit. | |
OUTPUT_DISTRIBLOAD_UNIT | 111 | The output distributed load unit. | |
INPUT_SPRINGCONSTANT_UNIT | 112 | The input spring constant unit. | |
OUTPUT_MASSPERLENGTH_UNIT | 113 | The output mass per length unit. | |
INPUT_SURFACELOAD_UNIT | 120 | The input surface load unit. | |
OUTPUT_SURFACELOAD_UNIT | 121 | The output surface load unit. | |
INPUT_STRENGTH_UNIT | 122 | The input strength unit. | |
OUTPUT_STRESS_UNIT | 123 | The output stress unit. | |
INPUT_MODULUS_UNIT | 124 | The input modulus unit. | |
INPUT_DENSITY_UNIT | 131 | The input density unit. | |
INPUT_MOMENT_UNIT | 200 | The input moment unit. | |
OUTPUT_MOMENT_UNIT | 201 | The output moment unit. | |
INPUT_DISTRIBMOMENT_UNIT | 205 | The input distributed moment unit. | |
INPUT_ROTSPRINGCONST_UNIT | 210 | The input rotation spring constant unit. | |
INPUT_TEMPERATURE_UNIT | 300 | The input temperature unit. | |
OUTPUT_TEMPERATURE_UNIT | 301 | The output temperature unit. | |
INPUT_THERMDILATCOEFF_UNIT | 310 | The input thermal dilatation coefficient unit. | |
INPUT_FACTOR_UNIT | 400 | The input factor unit. | |
INPUT_DATE_UNIT | 401 | The input date unit. | |
INPUT_DATE_TIME_MIN_UNIT | 402 | The input date time minutes unit. | |
INPUT_DATE_TIME_SEC_UNIT | 403 | The input date time seconds unit. | |
INPUT_LENGTH_FRACTIONAL_IMPERIAL | 1005 | The input length, fractional imperial. | |
INPUT_DEFORMATION_FRACTIONAL_IMPERIAL | 1305 | The input deformation, fractional imperial. | |
INPUT_DIMENSION_FRACTIONAL_IMPERIAL | 1405 | The input dimension, fractional imperial. | |
INPUT_RADIUSOFINERTIA_FRACTIONAL_IMPERIAL | 1605 | The input radius of inertia, fractional imperial. | |
OUTPUT_LENGTH_FRACTIONAL_IMPERIAL | 1105 | The output length, fractional imperial. | |
OUTPUT_DEFORMATION_FRACTIONAL_IMPERIAL | 1305 | The output deformation, fractional imperial. |
See Also