Distance Class

The Distance class contains methods for calculating the distance between geometric objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dDistance

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public static class Distance

The Distance type exposes the following members.

Methods
  NameDescription
Public methodStatic memberPointToLine
Returns the distance between the given point and line.
Public methodStatic memberPointToLineSegment
Returns the distance between the given point and line segment.
Public methodStatic memberPointToPlane
Returns the distance between the given point and plane.
Public methodStatic memberPointToPoint
Returns the distance between the given two points.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next