DimensionSetBase Class |
The DimensionSetBase class is the common base class for all the different dimension sets.
The dimension set base cannot be instantiated.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetBase
Tekla.Structures.DrawingStraightDimensionSet
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetBase
Tekla.Structures.DrawingStraightDimensionSet
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DimensionSetBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The dimension set attributes.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
Methods
Name | Description | |
---|---|---|
AddToDimensionSet |
Adds a dimension set to the current dimension set.
GetObjects |
Gets the children straight dimensions of the current straight dimension set.
| |
GetObjects(Type) |
Gets the children straight dimensions of the current straight dimension set that are of certain types.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
IsEqual |
Compares the current object with the given object.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also