DimensionSetBaseAttributesDimensionValuePrecisions Enumeration |
The value precisions for the dimensions.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
Whole | 1 | The value is rounded to the nearest whole (1). | |
OnePerTwo | 2 | The value is rounded to the nearest half (1/2). | |
OnePerThree | 3 | The value is rounded to the nearest third (1/3). | |
OnePerFour | 4 | The value is rounded to the nearest fourth (1/4). | |
OnePerEight | 8 | The value is rounded to the nearest eighth (1/8). | |
OnePerSixteen | 16 | The value is rounded to the nearest sixteenth (1/16). | |
OnePerThirtytwo | 32 | The value is rounded to the nearest thirtysecond (1/32). | |
OnePerTen | 10 | The value is rounded to one decimal (1/10). | |
OnePerHundred | 100 | The value is rounded to two decimals (1/100). | |
OnePerThousand | 1000 | The value is rounded to three decimals (1/1000). | |
TwoAndHalfPerOne | -25 | Value is rounded to nearest 2.5mm | |
FivePerOne | -50 | Value is rounded to nearest 5mm | |
TenPerOne | -100 | Value is rounded to nearest 10mm |
See Also