DimensionSetBaseAttributesDimensionFormatAttributes Class |
The DimensionFormatAttributes class controls the precision, format and unit of the dimension.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionFormatAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionFormatAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DimensionSetBaseAttributesDimensionFormatAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DimensionSetBaseAttributesDimensionFormatAttributes |
Creates a new dimension format attributes instance. By default the format rounds the dimension value to
the nearest whole and shows it with no decimals. The unit is selected automatically.
| |
DimensionSetBaseAttributesDimensionFormatAttributes(DimensionSetBaseAttributesDimensionValuePrecisions, DimensionSetBaseAttributesDimensionValueFormats, DimensionSetBaseAttributesDimensionValueUnits) |
Creates a new dimension format attributes instance with the given parameters.
|
Properties
Name | Description | |
---|---|---|
Format |
The format of the dimension.
| |
Precision |
The precision of the dimension.
| |
Unit |
Gets or sets the unit of the dimension. Changing this attribute
does not have any effect if the dimension measures an angle.
| |
UseDigitGrouping |
Gets or sets a value indicating whether digit grouping should be used or not.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also