DimensionSetBaseAttributes Class |
The DimensionSetBaseAttributes class is the base class for all dimension set attributes.
The class contains attributes that are common to all dimension sets.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingAngleDimensionAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingRadiusDimensionAttributes
Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingAngleDimensionAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingRadiusDimensionAttributes
Tekla.Structures.DrawingStraightDimensionSetStraightDimensionSetAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DimensionSetBaseAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DimensionSetBaseAttributes |
Creates a new default dimension set base attributes instance that loads standard attributes.
| |
DimensionSetBaseAttributes(String) |
Creates a new dimension set base attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Arrowhead |
The arrowhead attributes of the dimension.
| |
Color |
The color of the dimension line.
| |
Format |
The format attributes of the dimension.
| |
Placing |
The placing attributes of the dimension.
| |
Text |
The text attributes of the dimension.
| |
TransparentBackground |
The dimension text background transparency. (transparent/opaque)
| |
TrueColor |
The true color (RGB enabled) of the dimension line.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) | |
LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |
See Also