DimensionBase Class |
The DimensionBase class is the common base class for all the different dimensions.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingAngleDimension
Tekla.Structures.DrawingCurvedDimensionBase
Tekla.Structures.DrawingRadiusDimension
Tekla.Structures.DrawingStraightDimension
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionBase
Tekla.Structures.DrawingAngleDimension
Tekla.Structures.DrawingCurvedDimensionBase
Tekla.Structures.DrawingRadiusDimension
Tekla.Structures.DrawingStraightDimension
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DimensionBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
Hideable |
Accesses the information if this object is hidden or not or if it should be.
Methods
Name | Description | |
---|---|---|
GetDimensionSet |
Gets the dimension set the current dimension belongs to.
| |
GetDimensionSet(Boolean) |
Gets the dimension set the current dimension belongs to.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
IsEqual |
Compares the current object with the given object.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also