DetailTypeAttribute Class |
The DetailTypeAttribute class is used for storing the detail type.
Based on the type the system will then position the detail in the creation.
The attribute is initialized from the custom attribute
[DetailType(DetailTypeEnum.END)]
in the connection source.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DetailTypeAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DetailTypeAttribute(Int32) |
The custom attribute [DetailType()] uses this to store the type of the detail to the system.
This is not to be used by itself.
| |
DetailTypeAttribute(DetailTypeEnum) |
The custom attribute [DetailType()] uses this to store the type of the detail to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Type |
The custom attribute [DetailType()] uses this to store the type of the detail to the system.
This is not to be used by itself.
|
See Also