DetailMarkDetailMarkAttributes Class |
The DetailMarkAttributes class is the attributes class for detail marks.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDetailMarkDetailMarkAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDetailMarkDetailMarkAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The DetailMarkDetailMarkAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DetailMarkDetailMarkAttributes |
Creates a new default DetailMarkAttributes instance that loads standard attributes.
| |
DetailMarkDetailMarkAttributes(String) |
Creates a new DetailMarkAttributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
BoundaryLineColor | Obsolete. | |
BoundaryLineType | Obsolete. | |
BoundaryShape |
The detail mark boundary shape.
| |
BoundingLine |
Gets or sets the line type.
| |
MarkName |
The detail mark name.
| |
MarkSymbolAttributes |
The detail mark symbol attributes.
| |
MarkSymbolColor | ||
TagsAttributes |
The attributes for detail mark tags.
| |
TrueMarkSymbolColor |
The true color (rgb enabled) of the detail mark symbol.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also