DetailMark Constructor (View, Point, Point, Point, DetailMarkDetailMarkAttributes) |
Creates a new detail mark instance with the given positions and attributes.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public DetailMark( View view, Point centerPoint, Point boundaryPoint, Point labelPoint, DetailMarkDetailMarkAttributes detailMarkAttributes )
Parameters
- view
- Type: Tekla.Structures.DrawingView
The view to be used. - centerPoint
- Type: Tekla.Structures.Geometry3dPoint
The center point to be used. - boundaryPoint
- Type: Tekla.Structures.Geometry3dPoint
The boundary point to be used. - labelPoint
- Type: Tekla.Structures.Geometry3dPoint
The label point to be used. - detailMarkAttributes
- Type: Tekla.Structures.DrawingDetailMarkDetailMarkAttributes
The detail mark attributes to be used.
See Also