ShapeItemDeleteMetadata Method |
Delete the Shape item's metadata.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- key
- Type: SystemString
The key of metadata.
Return Value
Type: BooleanTrue if success or False if key not found or deletion failed.
Examples
public void SetMetaDataTest() { var polymesh = CreateSomeValidBrep(); var shapeItem = new ShapeItem { Name = "TestFileName", ShapeFacetedBrep = polymesh, UpAxis = ShapeUpAxis.Z_Axis }; shapeItem.Insert(); shapeItem.SetMetadata("test", ShapeMetadataTypeEnum.Text, "testvalue", "", ""); shapeItem.DeleteMetadata("test"); }
See Also