DeformingData Class

The DeformingData class holds information about the deforming of parts. Deformed parts are parts that have been warped, cambered or shortened.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelDeformingData

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class DeformingData

The DeformingData type exposes the following members.

Constructors
  NameDescription
Public methodDeformingData
Instantiates a deforming data instance.
Top
Properties
  NameDescription
Public propertyAngle
The angle of the part at its start point, relative to the part reference line.

For example, if the beam is warped 45 degrees at the end point, in the Angle field the value is 0, and the value is 45 in the Angle2 field.

Public propertyAngle2
The angle of the part at its end point, relative to the part reference line.

For example, if the beam is warped 45 degrees at the end point, in the Angle field the value is 0, and the value is 45 in the Angle2 field.

Public propertyCambering
The degree of cambering.
Public propertyShortening
The degree of shortening.
Top
Examples
The following example inserts a deformed beam:
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           Beam MyBeam = new Beam();
           MyBeam.DeformingData.Angle = 0.0;
           MyBeam.DeformingData.Angle2 = 45.00;
           MyBeam.DeformingData.Cambering = 10.0;
           MyBeam.DeformingData.Shortening = 20.0;
           MyBeam.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next